Cómo funciona JustAnswer:
  • Preguntar a un Experto
    Los expertos tienen muchos conocimientos valiosos y están dispuestos a ayudar en cualquier pregunta. Credenciales confirmadas por una empresa de verificación perteneciente a Fortune 500.
  • Obtener una respuesta profesional
    Por correo electrónico, mensaje de texto o notificación mientras espera en su sitio. Haga preguntas de seguimiento si lo necesita.
  • Garantía de satisfacción plena
    Garantizamos tu satisfacción.
Formule su propia pregunta a Rubén Díaz
Rubén Díaz
Rubén Díaz, Técnico en computación, informática
Categoría: Informática
Clientes satisfechos: 389
Experiencia:  Más de 7 años de experiencia en soporte informático in-situ y remoto, con conocimientos en equipos Windows, Mac, Smartphone y periféricos.
51963821
Escriba su pregunta sobre Informática aquí...
Rubén Díaz está en línea ahora

Sobre Excell.Como realizar la siguiente formula, quiero

Pregunta del cliente:

Sobre Excell. Como realizar la siguiente formula, quiero que una celda realice todo lo que indico. c3 es la celda contiene el dato. c4 es la celda contiene el dato del %. c5 es la celda donde quiero salga la formula indico, hay que reallizar:


 


si c3 < 80% = 0


si c3 >80% multiplicar c3 * 0,50


si c3 > 80% y < 100% = c3 * 0,75


si c3 > 100% = c3

Enviada: hace 5 año.
Categoría: Informática
Experto:  Rubén Díaz escribió hace 5 año.

Rubén Díaz :

Bienvenido al servicio de asistencia informática de Just answer.

Rubén Díaz :

Hola, buenas noches,


 


Siguiendo el razonamiento propuesto para la fórmula de excel, me encuentro con que posiblemente falta una celda más o que no se haya especificado bien parte del enunciado, agrego en negrita la referencia que hace falta cuando usted indica lo siguiente:


 


si c3 < 80% (¿80% de qué valor?, por ejemplo podría ser 80% de C2, siempre y cuando C2 tubiera un valor) = 0


si c3 > 80% (¿80% de qué valor?) multiplicar c3 * 0,50


si c3 > 80% (¿80% de qué valor?) y < 100% (¿100% de qué valor?) = c3 * 0,75


si c3 > 100%(¿100% de qué valor?) = c3


 


Por favor, específiqueme dicho detalle para facilitarle una opción.


 


Saludos.

Customer:

Hola,


 


El valor del tanto por ciento (%) lo recoge una casilla que es la C4.


 


Un saludo,

Rubén Díaz :

Respondiendo a su planteamiento, y aunque a mi parecer hay algunas incoherencias (o es que aún no lo tengo claro), le adjunto el razomiento aplicado según lo planteado.


 


La fórmula que iría en C5 sería: =SI(C3<C4;0;SI(C3>C4;C3*0,5;SI(Y(C3>C4;C3<100%);C3*0,75;SI(C3>100%;C3))))


 


Consideraciones a tener en cuenta:


La celda C3 debe de tener el formato de porcentaje si la celda C4 contiene un porcentaje.


 


Incoherencias:


si c3 > 80% multiplicar c3 * 0,50


si c3 > 100%= c3


 


Por ejemplo si C3 fuese 110, se cumpliria los 2 casos, pero se aplicaría la primera condicíón; es decir C3 * 0,50 y no = C3.


 


Quedo a la espera de sus comentarios.


 


Saludos.

Customer:

Perdon, el requisito si c3 > 80%multiplicar c3 * 0,50 (no iria).


 


Estos serian los requisitos.


si c3 < 80% = 0


si c3 > 80% y < 100% = c3 * 0,75


si c3 > 100% = c3


 


 

Rubén Díaz :

De acuerdo, en ese caso la fórmula que iría en C5 sería:


 


=SI(C3<C4;0;SI(Y(C3>C4;C3<100%);C3*0,75;SI(C3>100%;C3)))


 


Por favor compruebelo y si le he sido de ayuda, no olvide calificar mi respuesta.


 


Saludos.

Customer:

Solo me quedaria que cuando sea menor de 80% el campo se ponga de color rojo

Rubén Díaz :

Disculpe la demora,


 


En éste último caso propuesto, la mejor opción sería aplicar el formato condicional en dicha celda para que se ponga de color rojo, los pasos serían los siguientes (se aplica a Microsoft Office 2010):


 


Estando el cursor en la celda deseada, dentro de la pestaña Inicio haga clic en Formato condicional, Resaltar reglas de celdas, Es menor que..., en la ventana que aparece ponga el valor 80 y al lado derecho elija el color deseado.


 


Con ésta configuración la celda cambiará de color automáticamente si el valor que contiene es menor a 80


 


Saludos.

Rubén Díaz y otros otros especialistas en Informática están preparados para ayudarle