Cómo funciona JustAnswer:
  • Preguntar a un Experto
    Los expertos tienen muchos conocimientos valiosos y están dispuestos a ayudar en cualquier pregunta. Credenciales confirmadas por una empresa de verificación perteneciente a Fortune 500.
  • Obtener una respuesta profesional
    Por correo electrónico, mensaje de texto o notificación mientras espera en su sitio. Haga preguntas de seguimiento si lo necesita.
  • Garantía de satisfacción plena
    Garantizamos tu satisfacción.
Formule su propia pregunta a elbrujomdq
elbrujomdq
elbrujomdq, Técnico informático
Categoría: Informática
Clientes satisfechos: 495
Experiencia:  Analista de sistemas, Desarrollo de Software
67837258
Escriba su pregunta sobre Informática aquí...
elbrujomdq está en línea ahora

"sudo apt-get update", OK. "sudo apt-get upgrade" Problem. Xubuntu

Pregunta del cliente:

"sudo apt-get update", OK.
"sudo apt-get upgrade" Problem.
Xubuntu 13.04
Copia/pegar:
[email protected]:~$ sudo apt-get upgrade
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
0 actualizados, 0 se instalarán, 0 para eliminar y 0 no actualizados.
1 no instalados del todo o eliminados.
Se necesita descargar 0 B/30,8 MB de archivos.
Se utilizarán 0 B de espacio de disco adicional después de esta operación.
¿Desea continuar [S/n]?
dpkg: error al procesar linux-image-extra-3.8.0-25-generic (--configure):
el paquete linux-image-extra-3.8.0-25-generic no está listo para configurarse
no se puede configurar (estado actual `half-installed')
No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
Se encontraron errores al procesar:
linux-image-extra-3.8.0-25-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)
[email protected]:~$ http://www.ubuntu-es.org/user/reset/202104/1373809863/Tdffe5Xz68LGDlicNbdTUuEoJevHFvPThD-M2ILar2M

He probado con "-f" pero no se soluciona.
Enviada: hace 4 año.
Categoría: Informática
Experto:  elbrujomdq escribió hace 4 año.
Buen dia,

Ud se comunico con el sistema de preguntas JustAnswer, ud hace una pregunta y obtiene respuestas. Es el servicio que contrato y pago.

Cual es su pregunta?
Cliente: escribió hace 4 año.

No encuentro su respuesta.


Al escribir en terminal "sudo apt-get upgrade", no me actualiza y responde:


dpkg: error al procesar linux-image-extra-3.8.0-25-generic (--configure):
el paquete linux-image-extra-3.8.0-25-generic no está listo para configurarse
no se puede configurar (estado actual `half-installed')
No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
Se encontraron errores al procesar:
linux-image-extra-3.8.0-25-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)


¿Tiene arreglo? distro= Xubuntu.

Experto:  elbrujomdq escribió hace 4 año.
De acuerdo,

Estaria faltando el motivo, si solo dice:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Puede comprobar si tiene espacio disponible en las particiones

-Desde cuando le sucede esto?
Cliente: escribió hace 4 año.

En "Sistema"- "Analizador de uso de disco"


En d.d. uso 6,8 Gb de 117 Gb.
En RAM? Carpeta personal, con gráficos, sale "USO", en rojo 100%. y poca cosa mas en demás carpetas.


La RAM es de 1 Gb, el uso marca 98%.

Experto:  elbrujomdq escribió hace 4 año.


-Desde cuando le sucede esto?

 

Desde consola puede probar cada uno de estos comandos en el orden que le indico:

 

sudo apt-get clean

 

sudo apt-get autoremove

 

sudo apt-get update

 

sudo apt-get upgrade

 

sudo apt-get -f install

Cliente: escribió hace 4 año.

Hará un mes. No tengo apenas nada almacenado. Acostumbro a usarlo en verano, para no subir arriba, bajotecho, por el calor y lo uso básicamente, para los mails y las redes sociales.
tengo por costumbre, al encender, empezar por el "update" y el "upgrade".


He hecho dos veces limpieza con el BleachBit.

Cliente: escribió hace 4 año.

Después de hacer uno a uno los comandos, ha acabado igual: copio último comando:


[email protected]:~$ sudo apt-get -f install
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
0 actualizados, 0 se instalarán, 0 para eliminar y 0 no actualizados.
1 no instalados del todo o eliminados.
Se necesita descargar 0 B/30,8 MB de archivos.
Se utilizarán 0 B de espacio de disco adicional después de esta operación.
dpkg: error al procesar linux-image-extra-3.8.0-25-generic (--configure):
el paquete linux-image-extra-3.8.0-25-generic no está listo para configurarse
no se puede configurar (estado actual `half-installed')
No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
Se encontraron errores al procesar:
linux-image-extra-3.8.0-25-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)
[email protected]:~$

Cliente: escribió hace 4 año.

He copiado de uno en uno los cinco "sudo", al finalizar -f install, sale:


[email protected]:~$ sudo apt-get -f install
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
0 actualizados, 0 se instalarán, 0 para eliminar y 0 no actualizados.
1 no instalados del todo o eliminados.
Se necesita descargar 0 B/30,8 MB de archivos.
Se utilizarán 0 B de espacio de disco adicional después de esta operación.
dpkg: error al procesar linux-image-extra-3.8.0-25-generic (--configure):
el paquete linux-image-extra-3.8.0-25-generic no está listo para configurarse
no se puede configurar (estado actual `half-installed')
No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
Se encontraron errores al procesar:
linux-image-extra-3.8.0-25-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)
[email protected]:~$

Experto:  elbrujomdq escribió hace 4 año.
Podria editar el log de error y postearme por aca que indica?

/var/log/dpkg.log
Cliente: escribió hace 4 año.

installArchives() failed: dpkg: error processing linux-image-extra-3.8.0-25-generic (--remove):
Package is in a very bad inconsistent state - you should
reinstall it before attempting a removal.
No apport report written because MaxReports is reached already
Errors were encountered while processing:
linux-image-extra-3.8.0-25-generic
Error in function:


____________


 


No se editar el log del error.


Si he intentado, desinstalar desde el Centro de Solware de Ubuntu:
Linux Kernel image for versión 3.8.0 on 32 bits x 86 SMP
linux-image-extra-3.8.0-25-generic


Instalado el 15-06-2013
No me deja desinstalarlo, cuando ja está casi desinstalado, sale el error que he copiado arriba.
Entiendo en mi pobre inglés, que el programa está roto y que debo desinstalarlo, para volverlo a instalar o algo así. Pero al intentar desinstalarlo, desde el centro de solware, no me deja.

Experto:  elbrujomdq escribió hace 4 año.
De acuerdo,

Si el paquete quedo por la mitad corrupto, eso dice. Dice que lo desinstale y lo instale nuevamente.

Para editar el log, abra una terminal y escribe: nano /var/log/dpkg.log

Pegueme que dice
Cliente: escribió hace 4 año.

2013-07-01 11:33:04 startup packages configure
2013-07-01 11:34:57 startup packages configure
2013-07-01 12:56:27 startup packages configure
2013-07-01 12:57:40 startup packages configure
2013-07-01 13:02:24 startup packages configure
2013-07-01 13:05:02 startup packages configure
2013-07-02 12:14:02 startup archives unpack
2013-07-02 12:14:11 upgrade libqt4-svg:i386 4:4.8.4+dfsg-0ubuntu9 4:4.8.4+dfsg-0ubuntu9.1
2013-07-02 12:14:11 status half-configured libqt4-svg:i386 4:4.8.4+dfsg-0ubuntu9
2013-07-02 12:14:11 status unpacked libqt4-svg:i386 4:4.8.4+dfsg-0ubuntu9
2013-07-02 12:14:11 status half-installed libqt4-svg:i386 4:4.8.4+dfsg-0ubuntu9
2013-07-02 12:14:12 status half-installed libqt4-svg:i386 4:4.8.4+dfsg-0ubuntu9
2013-07-02 12:14:12 status unpacked libqt4-svg:i386 4:4.8.4+dfsg-0ubuntu9.1
2013-07-02 12:14:12 status unpacked libqt4-svg:i386 4:4.8.4+dfsg-0ubuntu9.1
2013-07-02 12:14:12 upgrade libqt4-qt3support:i386 4:4.8.4+dfsg-0ubuntu9 4:4.8.4+dfsg-0ubuntu9.1
2013-07-02 12:14:12 status half-configured libqt4-qt3support:i386 4:4.8.4+dfsg-0ubuntu9
2013-07-02 12:14:12 status unpacked libqt4-qt3support:i386 4:4.8.4+dfsg-0ubuntu9
2013-07-02 12:14:12 status half-installed libqt4-qt3support:i386 4:4.8.4+dfsg-0ubuntu9
2013-07-02 12:14:13 status half-installed libqt4-qt3support:i386 4:4.8.4+dfsg-0ubuntu9
2013-07-02 12:14:13 status unpacked libqt4-qt3support:i386 4:4.8.4+dfsg-0ubuntu9.1
2013-07-02 12:14:13 status unpacked libqt4-qt3support:i386 4:4.8.4+dfsg-0ubuntu9.1
2013-07-02 12:14:14 upgrade libqt4-opengl:i386 4:4.8.4+dfsg-0ubuntu9 4:4.8.4+dfsg-0ubuntu9.1
2013-07-02 12:14:14 status half-configured libqt4-opengl:i386 4:4.8.4+dfsg-0ubuntu9
2013-07-02 12:14:14 status unpacked libqt4-opengl:i386 4:4.8.4+dfsg-0ubuntu9
2013-07-02 12:14:14 status half-installed libqt4-opengl:i386 4:4.8.4+dfsg-0ubuntu9
2013-07-02 12:14:14 status half-installed libqt4-opengl:i386 4:4.8.4+dfsg-0ubuntu9
2013-07-02 12:14:14 status unpacked libqt4-opengl:i386 4:4.8.4+dfsg-0ubuntu9.1
2013-07-02 12:14:14 status unpacked libqt4-opengl:i386 4:4.8.4+dfsg-0ubuntu9.1
2013-07-02 12:14:15 upgrade libqt4-designer:i386 4:4.8.4+dfsg-0ubuntu9 4:4.8.4+dfsg-0ubuntu9.1
2013-07-02 12:14:15 status half-configured libqt4-designer:i386 4:4.8.4+dfsg-0ubuntu9
2013-07-02 12:14:15 status unpacked libqt4-designer:i386 4:4.8.4+dfsg-0ubuntu9
2013-07-02 12:14:15 status half-installed libqt4-designer:i386 4:4.8.4+dfsg-0ubuntu9
2013-07-02 12:14:16 status half-installed libqt4-designer:i386 4:4.8.4+dfsg-0ubuntu9
2013-07-02 12:14:16 status unpacked libqt4-designer:i386 4:4.8.4+dfsg-0ubuntu9.1
2013-07-02 12:14:16 status unpacked libqt4-designer:i386 4:4.8.4+dfsg-0ubuntu9.1
2013-07-02 12:14:16 upgrade libqtgui4:i386 4:4.8.4+dfsg-0ubuntu9 4:4.8.4+dfsg-0ubuntu9.1
2013-07-02 12:14:16 status half-configured libqtgui4:i386 4:4.8.4+dfsg-0ubuntu9
2013-07-02 12:14:16 status unpacked libqtgui4:i386 4:4.8.4+dfsg-0ubuntu9
2013-07-02 12:14:17 status half-installed libqtgui4:i386 4:4.8.4+dfsg-0ubuntu9
2013-07-02 12:14:18 status half-installed libqtgui4:i386 4:4.8.4+dfsg-0ubuntu9


^G Ver ayuda ^O Guardar ^R Leer Fich ^Y RePág. ^K Cortar Texto ^C Pos actual
^X Salir ^J Justificar ^W Buscar ^V Pág. Sig. ^U PegarTxt ^T Ortografía

Experto:  elbrujomdq escribió hace 4 año.
De acuerdo, debe ir avanzando de pagina hasta el dia de hoy dado que eso corresponde al 2/7

Con las teclas control V va avanzando de pagina
Cliente: escribió hace 4 año.

He llegado hasta aquí, ya no hace nada más:


GNU nano 2.2.6 Archivo: /var/log/dpkg.log Modificado


2013-07-15 22:49:42 status half-installed linux-image-extra-3.8.0-25-generic:i386 3.8.0-25.37
2013-07-15 22:49:43 startup packages configure
2013-07-15 22:55:42 startup packages remove
2013-07-15 22:55:42 status half-installed linux-image-extra-3.8.0-25-generic:i386 3.8.0-25.37
2013-07-15 22:55:42 startup packages configure
2013-07-15 23:04:32 startup packages remove
2013-07-15 23:04:32 status half-installed linux-image-extra-3.8.0-25-generic:i386 3.8.0-25.37
2013-07-15 23:04:33 startup packages configure
2013-07-15 23:59:57 startup packages configure


 

Experto:  elbrujomdq escribió hace 4 año.
De acuerdo, por lo visto el paquete quedo en la mitad de la instalacion algo que veniamos manejando.

Una solucion seria cambiar el status. El estado de half a instalado. Para eso

Ir a
/var/lib/dpkg/status

nano /var/lib/dpkg/status

buscar el paquete en cuestión y cambiarle el estado "Status:" a
"install ok installed" [1]

grabar con las teclas Control O

Cuenteme como le fue
Cliente: escribió hace 4 año.

[email protected]:~$ /var/lib/dpkg/status
bash: /var/lib/dpkg/status: Permiso denegado
[email protected]:~$ sudo apt-get /var/lib/dpkg/status
[sudo] password XXXXX jaume:
E: Operación inválida: /var/lib/dpkg/status
[email protected]:~$

Como verás, no paso de /var/lib/dpkg/status

Experto:  elbrujomdq escribió hace 4 año.
Buen dia,

Le esta pidiendo la clave de administrador, es necesaria a este nivel de accion sobre el equipo

Desde la terminal puede poner: su enter e ingrese la clave, posteriormente

nano /var/lib/dpkg/status

buscar el paquete en cuestión y cambiarle el estado "Status:" a
"install ok installed" [1]

grabar con las teclas Control O
Cliente: escribió hace 4 año.

En [sudo] passport for jaume: Ya pongo la clave de administrador, alegret. Siempre me lo ha pedido cuando aplico empiezo.
Sólo instalé mi passport. Si es algo diferente mi enter y mi clave, nunca he creado nada al respecto.

Experto:  elbrujomdq escribió hace 4 año.
Desde la terminal, puso su y ahi ingresa la clave?

No use sudo en este caso
Cliente: escribió hace 4 año.

Contraseña:
su: Fallo de autenticación
[email protected]:~$

Debe ser cosa diferente la Contraseña del Passwort.


Nunca he usado contasenya, si en cambio Passwort, que al parecer no debe ser lo mismo.

Experto:  elbrujomdq escribió hace 4 año.
Si claro, la contraseña de usuario jaume no es la misma que la de administrador.

Demos el paso atras, quien le instalo el linux?
Cliente: escribió hace 4 año.

Yo, quemando un DVD. Antes tenía Ubuntu y LinuxMint, peró al ir creciendo, desde hace unos dos años, bajé a Xubuntu.


He quemado varias distros, y provado live CD, Debian, Trisquel Guardamar, Open Suse, etc. pero nunca había trebajado con la terminal, y no he pasado del update y el upgrade. En una ocasión, vi como incorporar un pasword y lo hice y hasta ahora me ha funcionado, al actualizar, cuando antes, no me pedía nada.

Experto:  elbrujomdq escribió hace 4 año.
a ver, su ud lo instalo es la clave que le pide inicialmente antes de crear a un usuario, la que equivaldria al usuario root.

Alguna vez desde la terminal le quedo asi:

root @jaume-Compaq-Presario-C700-Notebook-PC:~$
Cliente: escribió hace 4 año.

No.


 

Experto:  elbrujomdq escribió hace 4 año.
Puede fijarse desde el menu en usuarios que usuarios ve?

Sin la clave de administrador no podemos seguir, ya que ese archivo que hay que modificar requiere permiso para modificarlo(grabar)
Cliente: escribió hace 4 año.

En Ajustes de usuarios sale:


Icono a la izquierda con jaume, i debajo mas suave jaume.


A la derecha, otro icono mas pequeño y jaume.


Debajo, Tipo de cuenta: personalizado,


y debajo, Contrasenya: Preguntar al iniciar sesión.

Experto:  elbrujomdq escribió hace 4 año.
De acuerdo, por lo visto su usuario es el unico creado.

Hace cuanto que instalo el ubuntu?
Cliente: escribió hace 4 año.

Unos dos años, Xubuntu 12.10, se actualizó automáticamente al salir 13.04.

Experto:  elbrujomdq escribió hace 4 año.
De acuerdo, le comento. Tenemos unas instancias como para intentar recuperar la clave de root, de ser exitoso podriamos cambiar el status del archivo a ver si permite la actualizacion. Todo esto es un supuesto, ya que podria no funcionar.

Llegada a esta instancia, deberia evaluar reinstalar el ubuntu para conocer la clave de admin por un futuro que la requiera y de paso que le quede sin falla la actualizacion que quedo en la mitad del rio...

Indiqueme cual es su opinion
Cliente: escribió hace 4 año.

Como funcionar, para lo que lo uso me funciona, y que si no actualizara por terminal, no me habría enterado, prefiero dejarlo así. Creo que si no ha salido, pronto saldrá la versión 13.10, entonces en vez de una actualización, haría una instalación limpia, y vigilaría al empezar la instalación el tema "root".
Gracias XXXXX XXXXX i lamento que haya sido tan pesado.
Sólo le pido si puede aclararme una duda.
Mi Compac Presario C700 ex-Vista Windows Básic, con Procesador Intel Celeron inside, com 1Gb RAM y 100 Gb d.d. ¿ es suficiente para que quepa cómodamente el Xubuntu? Siempre me hace dudar la RAM, cuando veo la composición del disco, si no será poco. por lo demás, no tengo ninguna queja, me funciona super rápido, tanto al abrir como al cerrar, como al navegar, mucho mas que la torre con Windows 7 (AMD, dual core, 8 Gb y 1 Tb). Respondo a esta última questión, espero su pequeño comentario y seguidamente daré por terminada mi consulta, valorándola, Gracias.


 

Experto:  elbrujomdq escribió hace 4 año.
De acuerdo, buen criterio. Tome nota de la clave de adminstrador dado que sin ella no podra instalar, ni desinstalar algun hardware, configuraciones, etc

De mi parte todo bien, linux no es como windows a la hora de algun problema, pero del mismo modo puede tenerlo 10 años sin que tenga que reinstalarlo, ni virus, ni dada raro. Nunca se pierde el control de la maquina, como ocurre lamentablemente con windows.

Con respecto al uso de los recursos, siempre es mejor desde linux. Realmente maneja bien la memoria y esa debe ser la diferencia que encuentra en la fluidez entre usar ese mismo equipo con vista que con linux (no importa la distro)

En las sucesivas versiones estaria bueno que intente si ud puede en duplicar la ram por un tema de fluidez, solo por eso. No es que lo requiera.

Tiene alguna otra consulta, sino procedemos a cerrar esta incidencia.

A disposicion para cualquier otra oportunidad y que continuen los exitos con linux (soy usuario de fedora)

Cordialmente,
Roberto



elbrujomdq y otros otros especialistas en Informática están preparados para ayudarle